Get the App
SLTechnology News&Howtos  ›  Network Security  › 

Resolve zabbix "ZBX_NOTSUPPORTED: Timeout while executing a shell script" error report

Shulou Source: shulou.com Published: 2022-06-01 04:34:37 10月05日 Update

As shown in the question, the error message appears when zabbix_server uses zabbix_get to obtain the data of the script corresponding to the custom "UserParameter".

[root@nmp01 scripts] # / usr/local/zabbix/bin/zabbix_get-s 127.0.0.1-k 8080connectNumZBX_NOTSUPPORTED: Timeout while executing a shell script.

Solution

(1) modify the zabbix_server.conf of zabbix_server:

[root@nmp01 scripts] # vim / usr/local/zabbix/etc/zabbix_server.conf

Modify the following parameters:

Timeout=30

Note: the timeout time is 30 seconds.

(2) modify the zabbix_agentd.conf of the zabbix_agentd where the script resides:

[root@nmp01 scripts] # vim / usr/local/zabbix/etc/zabbix_server.conf

Modify the following parameters:

Timeout=30

(3) restart the zabbix server and the client where the script resides:

[root@nmp01 scripts] # service zabbix_server restart [root@nmp01 scripts] # service zabbix_agentd restart

Tags: Script parameter location information customer client data solution time solution service Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Huawei Apple Microsoft Xiaomi Linux