Get the App
SLTechnology News&Howtos  ›  Database  › 

Zabbix downloads the percona plug-in to implement the monitoring MySQL steps

Shulou Source: shulou.com Published: 2022-06-01 18:06:11 10月03日 Update

This article is mainly about zabbix downloading percona plug-ins to achieve monitoring MySQL steps, if you are interested, let's take a look at this article, I believe that after reading zabbix download percona plug-ins to achieve monitoring MySQL steps for you more or less reference value.

Zabbix server and agent are already installed in the existing environment

1 download percona monitoring plug-in

Https://www.percona.com/downloads/percona-monitoring-plugins/LATEST/

The downloaded name is as follows: percona-zabbix-templates-1.1.8-1.noarch.rpm

2 upload the plug-in to the CVM

Rz

3 install the plug-in

Rpm-ivh percona-zabbix-templates-1.1.8-1.noarch.rpm

Directory structure after installation

[root@mongos01 ~] # rpm-ql percona-zabbix-templates

4 install the php environment

Yum install php php-mysql-y

5 copy the configuration file to the / etc/zabbix/zabbix_agentd.conf.d directory

Cp / var/lib/zabbix/percona/templates/userparameter_percona_mysql.conf / etc/zabbix/zabbix_agentd.conf.d

Enable the monitoring in this directory

Vim / etc/zabbix/zabbix_agentd.conf

Add this line of content

Include=/etc/zabbix/zabbix_agentd.d/*.conf

The modified configuration file of agent needs to be restarted to take effect.

/ etc/init.d/zabbix-agent restart

Shutting down Zabbix agent: [OK]

Starting Zabbix agent: [OK]

6 create database users for monitoring

GRANT SELECT, PROCESS, SUPER, REPLICATION CLIENT ON *. * TO 'zabbix'@'localhost' IDENTIFIED BY' zabbix'

Flush privileges

7 modify php configuration file

Change to the account password used for monitoring in the database

Vim / var/lib/zabbix/percona/scripts/ss_get_mysql_stats.php

$mysql_user = 'zabbix'

$mysql_pass = 'zabbix'

8 test whether the value can be obtained through the script

/ var/lib/zabbix/percona/scripts/get_mysql_stats_wrapper.sh gw

198635444

II. Zabbix web Import Monitoring template

1 download template with self-contained template will report the error of time format as follows

1 download the new template

Wget http://jaminzhang.github.io/soft-conf/Zabbix/zbx_percona_mysql_template.xml

2 Import template zbx_percona_mysql_template

3 add a template for the host

Three error reporting treatment

Monitoring error 1:

Received value [rm: cannot remove `/ tmp/localhost-mysql_cacti_stats.txt': Operation not permitted18880] is not suitable for value type [Numeric (float)]

[root@mysqlS03 tmp] # rm-rf localhost-mysql_cacti_stats.txt

[root@mysqlS03 tmp] # touch localhost-mysql_cacti_stats.txt

[root@mysqlS03 tmp] #

[root@mysqlS03 tmp] # chown-R zabbix:zabbix localhost-mysql_cacti_stats.txt

Four master-slave replication monitoring

1 run script check manually

Sh / var/lib/zabbix/percona/scripts/get_mysql_stats_wrapper.sh running-slave

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

0

2 modify the configuration file to add the account and password for monitoring

Modify the configuration file

Vim my.cnf

Add the following

User=zabbix

Password=zabbix

3 check again and find that it is gone.

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

Now you can monitor master-slave replication.

Is it helpful for you to download the details of the steps of monitoring MySQL by downloading the percona plug-in for zabbix? If you want to know more about it, you can continue to follow our industry information section.

Tags: Monitor plug-in template file configuration content step directory master-slave password data database environment script account check line host value interest Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Microsoft OPPO Reno vpn Shulou Information MySQL