Get the App
SLTechnology News&Howtos  ›  Database  › 

Error in MySQL log & # 039 how to solve the problem in provided the mandatory server-id'

Shulou Source: shulou.com Published: 2022-05-31 17:53:47 10月06日 Update

This article mainly explains "how to solve the problem of MySQL log error reporting 'haven't provided the mandatory server-id'". Interested friends may wish to have a look. The method introduced in this paper is simple, fast and practical. Next let the editor to take you to learn "MySQL log error report 'haven't provided the mandatory server-id' how to solve it"!

Startup MySQL reports an error. The error in the log file is as follows:

2016-03-19T09:30:20.325988Z 0 [ERROR] You have enabled the binary log, but you haven't provided the mandatory server-id. Please refer to the proper server start-up parameters documentation

2016-03-19T09:30:20.326024Z 0 [ERROR] Aborting

2016-03-19T09:30:20.326035Z 0 [Note] Binlog end

The reason for reporting the error:

When setting the bin log log, the server_id parameter was not set.

The server-id parameter is used to provide a separate ID for master and slave in replication to distinguish between master and slave. You need to set this parameter when opening binaries.

Solution:

[root@T400-kelong log] # vim / etc/my.cnf

# bin log

Server_id=100

Log-bin=/log/product-bin

At this point, I believe that everyone has a deeper understanding of "MySQL log error report 'haven't provided the mandatory server-id' how to solve", might as well come to the actual operation of it! Here is the website, more related content can enter the relevant channels to inquire, follow us, continue to learn!

Tags: Logs parameters content files methods time learning practical deeper binary interest reason practicality practical easy to operate more friends websites errors channels Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Docker OPPO Reno Microsoft Redmi Xiaomi