The zabbix service could not be started
I installed a zabbix monitor, and it went smoothly. Later, I didn't know what service could not start. The server always reminded me that port 10051 was not open, so I checked it carefully over and over again, and the service always failed to start:
Starting zabbix_server: / etc/init.d/functions: line 536: / etc/init.d//sbin/zabbix_server: No such file or directory
So I opened the / etc/init.d/zabbix_server configuration file
find
BASEDIR=/usr/local/zabbix/zabbix
The path is not right
It turned out that I carried out the execution.
Sed-I's _
When it was executed twice, I felt a special shortage of hands, and then the service could not be started, and then the BASEDIR=/usr/local/zabbix/zabbix in the startup files zabbix_server and zabbix_agentd was changed to BASEDIR=/usr/local/zabbix/ OK.
Vi zabbix_server
# Edit these to match your system settings
# Zabbix-Directory
BASEDIR=/usr/local/zabbix/
Service zabbix_server start
Starting zabbix_server: [OK]
Service zabbix_agentd start
Starting zabbix_agentd: [OK]
The following is a link to build a zabb:
Http://bguncle.blog.51cto.com/3184079/1330247