Get the App
SLTechnology News&Howtos  ›  Database  › 

The low-level mistake made by switchover to xxx

Shulou Source: shulou.com Published: 2022-06-01 21:29:49 10月04日 Update

1. Environment description

ORACLE 12CR1

RHEL 7.0

two。 Operation process

Switchover to xxx reports an error as follows:

$dgmgrl /

DGMGRL for Linux: Version 12.1.0.2.0-64bit Production

Copyright (c) 2000, 2013, Oracle. All rights reserved.

Welcome to DGMGRL, type "help" for information.

Connected as SYSDG.

DGMGRL > show configuration

Configuration-dg_config

Protection Mode: MaxAvailability

Members:

Orcl-Primary database

Orcldg-Physical standby database

Fast-Start Failover: DISABLED

Configuration Status:

SUCCESS (status updated 14 seconds ago)

DGMGRL > validate database orcl

Database Role: Primary database

Ready for Switchover: Yes

DGMGRL > validate database orcldg

Database Role: Physical standby database

Primary Database: orcl

Ready for Switchover: Yes

Ready for Failover: Yes (Primary Running)

DGMGRL > switchover to orcldg

Performing switchover NOW, please wait...

New primary database "orcldg" is opening...

Oracle Clusterware is restarting database "orcl"...

ORA-01017: invalid username/password; logon denied

Warning: You are no longer connected to ORACLE.

Shut down instance "orcl" of database "orcl"

Start up instance "orcl" of database "orcl"

DGMGRL >

DGMGRL > connect sys/oracle@orcl

Connected as SYSDBA.

DGMGRL > switchover to orcldg

Performing switchover NOW, please wait...

Error: ORA-16558: database specified for switchover is not a standby database

Failed.

Unable to switchover, primary database is still "orcldg"

DGMGRL > switchover to orcl

Performing switchover NOW, please wait...

New primary database "orcl" is opening...

Oracle Clusterware is restarting database "orcldg"...

Switchover succeeded, new primary is "orcl"

DGMGRL >

Tags: Process environment low-level error Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Xiaomi MySQL MariaDB OPPO Reno vpn