Get the App
SLTechnology News&Howtos  ›  Database  › 

Brief notes on oracle installation

Shulou Source: shulou.com Published: 2022-06-01 11:48:14 10月02日 Update

| 1 | configure user environment |

Vi / home/oracle/.bash_profile # adds the following code at the end

Export ORACLE_BASE=/data/oracle # oracle database installation directory

Export ORACLE_HOME=$ORACLE_BASE/product/11.2.0/db_1 # oracle database path

Export ORACLE_SID=orcl # oracle startup database instance name

Export ORACLE_TERM=xterm # xterm window mode installation

Export PATH=$ORACLE_HOME/bin:/usr/sbin:$PATH # add system environment variables

Export LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib # add system environment variables

Export LANG=C # to prevent garbled code during installation

Export NLS_LANG=AMERICAN_AMERICA.ZHS16GBK # sets the Oracle client character set, which must be consistent with the character set set when Oracle is installed, such as ZHS16GBK, otherwise there will be garbled characters in data import and export

2 | netca cannot be started:

Switch to root and run xhost +

3 | failed to start listening:

[oracle@oracle ~] $lsnrctl start since01

LSNRCTL for Linux: Version 11.2.0.1.0-Production on 09-JUN-2014 21:24:23

Copyright (c) 1991, 2009, Oracle. All rights reserved.

Starting / data/oracle/product/11.2.0/db_1/bin/tnslsnr: please wait...

TNSLSNR for Linux: Version 11.2.0.1.0-Production

System parameter file is / data/oracle/product/11.2.0/db_1/network/admin/listener.ora

Log messages written to / data/oracle/diag/tnslsnr/oracle/since01/alert/log.xml

Error listening on: (DESCRIPTION= (ADDRESS= (PROTOCOL=TCP) (HOST=202.102.110.203) (PORT=1529)

TNS-12545: Connect failed because target host or object does not exist

TNS-12560: TNS:protocol adapter error

TNS-00515: Connect failed because target host or object does not exist

Linux Error: 99: Cannot assign requested address

Listener failed to start. See the error message (s) above...

Modify the configuration file: / data/oracle/product/11.2.0/db_1/network/admin/listener.ora, change ip to the local address or, 127.0.0.1

4 | enterprise manager configuration failed due to the following error

Do not check the enterprise configuration when configuring dbca

Tags: Data configuration database environment garbled variables characters character sets system consistency code enterprise address instance client client file time pattern user Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Apple MariaDB Shulou Tech Info Linux OPPO Reno