The reason of error report when installing grid Software and its solution
This article mainly explained the "installation of grid software error reasons and solutions", the article explains the content is simple and clear, easy to learn and understand, the following please follow the editor's ideas slowly in depth, together to study and learn "install grid software error reasons and solutions" bar!
Operating system: CentOS7.5 single node
Oracle:11.2.0.4
Error message:
Failed to start the Clusterware. Last 20 lines of the alert log follow:
2019-03-11 11 Suzhou 331.158:
[client (5588)] CRS-2101:The OLR was formatted using version 3.
2019-03-11 11 Suzhou 3333 01.614:
[client (5613)] CRS-1001:The OCR was formatted using version 3.
Ohasd failed to start at / opt/app/11.2.0/grid/crs/install/roothas.pl line 377, line 4.
Solution:
1. First delete the configuration: / opt/app/11.2.0/grid/perl/bin/perl-I/opt/app/11.2.0/grid/perl/lib-I/opt/app/11.2.0/grid/crs/install / opt/app/11.2.0/grid/crs/install/roothas.pl-deconfig-force-verbose
two。 Re-execute root.sh
When Adding daemon to inittab appears when the root.sh script is executed, use root in another window to execute the following command immediately:
Dd if=/var/tmp/.oracle/npohasd of=/dev/null bs=1024 count=1 (wait for the successful execution of root.sh to cancel the command here by ctrl+c. )
OK, at this point the Grid installation passes.
Thank you for your reading, the above is the "installation of grid software error reasons and solutions" content, after the study of this article, I believe you on the installation of grid software error reasons and solutions to this problem have a deeper understanding, the specific use of the need for everyone to practice and verify. Here is, the editor will push for you more related knowledge points of the article, welcome to follow!