Get the App
SLTechnology News&Howtos  ›  Network Security  › 

Cacti Error:'145 "solution"

Shulou Source: shulou.com Published: 2022-06-01 06:38:23 10月03日 Update

Check one of the monitoring normally in the morning, and the cacti does not show the picture. There was a power outage yesterday. Troubleshooting:

1. Check that the service is normal

2. Check the connection of the service, normal

Check the log and report an error of 145.

An error is reported in the log as follows:

AM-CMDPHP: Poller [0] ERROR: SQL Assoc failed, Error:'145', SQL: "select poller_output.output, poller_output.time, poller_output.local_data_id, poller_item.rrd_path, poller_item.rrd_name, poller_item.rrd_num from (poller_output,poller_item) where (poller_output.local_data_id=poller_item.local_data_id and poller_output.rrd_name=poller_item.rrd_name) LIMIT 10000"

MySQL view, collector cache stopped working.

Mysql > select count (*) from poller_output;+-+ | count (*) | +-+ | 0 | +-+ 1 row in set (0.00 sec) mysql >

Solution:

1. Rebuild the collector cache (more convenient)

2. Database cleanup (empty poller_output table)

Truncate table poller_output

Return to normal:

Because the problem occurs only once a year, the parameters are not optimized here.

Tags: Log cache collector service check drawing parameter data database mode problem work monitoring Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno vpn Shulou Tech Info OPPO Reno Xiaomi Shulou Information