Solution and steps for Oracle client unable to connect to server
The client cannot connect to the server database due to network, configuration, file access permissions, whether the database service has been started, and other problems. The general troubleshooting steps are as follows:
1. Check whether the operating system level network is unobstructed
Ping 192.168.10.1
two。 Check whether the database layer network is unobstructed.
Tnsping myserverdb
3. Check whether the monitoring status is normal.
Lsnrctl status listener
4. If the second step fails, check whether the server listening configuration is correct.
The configuration of listening files is generally as follows
# Monitoring name
LISTENER=
(DISCRIPTION =
(ADDRESS= (PROTOCOL = TCP) (HOST=192.168.4.80) (PORT=1521))
)
# list of monitoring services
SID_LIST_LISTENER =
(
SID_LIST =
(SID_DESC =
(GLOBAL_DBNAME = orcl)
(ORACLE_HOME = F:\ app\ Administrator\ product\ 11.2.0\ dbhome_1)
(SID_NAME = orcl)
)
(SID_DESC =
)
...
)
5. Check whether the client tnsnames.ora configuration is correct
The protocol, hostname, port and database instance name should be consistent with the server.
6. Check the monitoring log listener.log file to find the corresponding log
7. Check file permissions
Check that the group to which the / var/tmp/.oracle file belongs must be an oinstall group before the client can connect