Get the App
SLTechnology News&Howtos  ›  Database  › 

Oracle 19C cannot enable the Auto Indexes feature

Shulou Source: shulou.com Published: 2022-06-01 04:43:19 10月03日 Update

Oracle 19C cannot enable the Auto Indexes feature

Environment:

OS:Red Hat Enterprise Linux Server release 7.5 (Maipo)

DB:Oracle Database 19c Enterprise Edition Release 19.0.0.0.0-Production Version 19.3.0.0.0

Description:

Recently, looking at the new features of Oracle 19C, I found that the Auto Indexes feature is particularly useful. I'd like to see the effect.

1 check that the auto_index feature is not enabled

SQL > select * from dba_auto_index_config

2 the following error occurred while enabling Automatic Indexing Times, this feature is not supported:

SQL > alter session set container=cjcpdb

SQL > EXEC DBMS_AUTO_INDEX.CONFIGURE ('AUTO_INDEX_MODE','IMPLEMENT')

BEGIN DBMS_AUTO_INDEX.CONFIGURE ('AUTO_INDEX_MODE','IMPLEMENT'); END

*

ERROR at line 1:

ORA-40216: feature not supported

ORA-06512: at "SYS.DBMS_SYS_ERROR", line 79

ORA-06512: at "SYS.DBMS_AUTO_INDEX_INTERNAL", line 9180

ORA-06512: at "SYS.DBMS_AUTO_INDEX", line 283

ORA-06512: at line 1

The cause of the problem:

The Auto Index feature is supported only on EXADATA systems systems.

Auto indexing will be allowed only in EXADATA systems, if not it will raise ORA-40216: feature not supported when we try it turn it on in non exadata systems.

ORA-40216 When Using Auto Index Feature (Doc ID 2570076.1)

APPLIES TO:

Oracle Database-Enterprise Edition-Version 19.3.0.0.0 and later Information in this document applies to any platform.

SYMPTOMS

When attempting to use auto index feature, e.g. DBMS_AUTO_INDEX.CONFIGURE ('AUTO_INDEX_MODE','IMPLEMENT'); it reports

ORA-40216: feature not supported ORA-6512: at "SYS.DBMS_SYS_ERROR", line 79 ORA-6512: at "SYS.DBMS_AUTO_INDEX_INTERNAL", line 9180 ORA-6512: at "SYS.DBMS_AUTO_INDEX", line 283 ORA-6512: at line 1

CHANGESCAUSE

This issue has been discussed in

Bug 30017206: ADW: AUTO INDEX FEATURE NOT WORKING IN FUTURE PRODUCTION

Closed as' Not a Bug.' Development explains: Auto indexing will be allowed only in EXADATA systems, if not it will raise ORA-40216: feature not supported when we try it turn it on in non exadata systems.

SOLUTION

Do not use AUTO INDEX FEATURE in non-exadata systems.

If you want to learn AUTO INDEX FEATURE, you can see the following link:

Https://docs.oracle.com/en/database/oracle/oracle-database/19/admin/managing-indexes.html#GUID-D1285CD5-95C0-4E74-8F26-A02018EA7999

Database Administrator's Guide-21 Managing Indexes21.7 Managing Auto Indexes

You can use the automatic indexing feature to configure and use auto indexes in an Oracle database to improve database performance.

.

Welcome to follow my Wechat official account "IT Little Chen" and learn and grow together!

Tags: Features learning support utility public reasons only effects times environment systems links errors problems faceted Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Docker MariaDB Shulou Information Huawei Linux