Win10 installation oracle12c encountered PRVF-3919
Environment and version:
OS:win10-64 bit
DatabaseServer:oracle12c edition 2
The author did not solve this problem completely, but chose to ignore it. But all the relevant methods have been tried.
PRVF-3919: unable to retrieve the value of the environment variable "PATH"
Reason: the path environment variable is too long. The value of the environment variable path exceeds 1023 characters and cannot be set.
Solution: modify the path environment variable.
Edit the Path and select all to copy all the paths into the text document.
Create a new system variable named path2
Cut all variables in Path and copy them into path2 and save them
Delete all selections in Path to default values
% SystemRoot%\ system32;%SystemRoot%;%SystemRoot%\ System32\ Wbem
Finally, add the% path2% reference path2 after the default value and save it.
Notice each semicolon.
Other possibilities for triggering PRVF-3919: 1: physical memory-this prerequisite tests whether the total physical memory of the system is at least 922MB (944128.0KB)
Expected value: NumberA
Actual value: NCMA
Error list:
PRVF-7531: unable to perform physical memory check on node "XP-201307311325"
Cause: unable to perform a physical memory check on the indicated node. Action: make sure you can access the specified node and view memory information. 2: physical memory-this prerequisite tests whether the total physical memory of the system is at least 922MB (944128.0KB)
Expected value: NumberA
Actual value: NCMA
Error list:
PRVF-7531: unable to perform physical memory check on node "XP-201307311325"
Cause: unable to perform a physical memory check on the indicated node. Action: make sure you can access the specified node and view memory information. 3: swap space size-this prerequisite tests whether the system has sufficient total swap space
Expected value: NumberA
Actual value: NCMA
Error list:
PRVF-7574: unable to perform swap space size check on node "XP-201307311325"
Cause: unable to perform swap space check on the indicated node. Action: make sure you can access the specified node and view the swap space information.
PRVF-7531: unable to perform physical memory check on node "XP-201307311325"
Cause: unable to perform a physical memory check on the indicated node. Action: make sure you can access the specified node and view memory information. 4: free space: XP-201307311325:C:\ DOCUME~1\ ADMINI~1\ LOCALS~1\ Temp this prerequisite tests whether the file system has enough free space.
Expected value: NumberA
Actual value: N/A5: architecture-this prerequisite tests whether the system has a certified architecture
Expected value: NumberA
Actual value: NCMA
Error list:
PRVF-7536: unable to perform architecture check on node "XP-201307311325"
Cause: the system architecture cannot be determined. Action: make sure you are using the correct package. 6:Environment variable: "PATH"-This test checks whether the length of the environment variable "PATH" does not exceed the recommended length.
Expected value: NumberA
Actual value: NCMA
In fact, if you look at the contents of these six errors, there are only two problems: first, the database cannot access the node, so you cannot check the memory, temporary space and other problems (such as the first five errors); second, the environment variable has no parameters, resulting in substandard length. Solutions to these two problems
1: enabling service service is usually started by default, because database installation depends on the support of this service.
2: set up a network shared C disk, and only at the command prompt can the net share centering memory and other information be placed on disk C (delete using net share C $/ del) to check the availability of the environment.
3: operation: my computer-> Advanced-> Environment variable-> system variable-> path; back up the original path value (be sure to back up)
Replace it with:% SystemRoot%\ system32;%SystemRoot%;%SystemRoot%\ System32\ Wbem; and see if there is path in the "user variable", and if so, delete it.
Then log out, log in again, and install again.
4: click the database software to execute as an administrator. By default, the system does not open this file as an administrator, so you cannot access disk C.
5: then log out, log in again, and install again.