11g expdp+dblink backup database error
11.2.0.4 Database, remote use of expdp+dblink to back up database error
The error is as follows:
ORA-31679: Table data object "HIS". AQULED_COM_SQL "has long columns, and longs can not be loaded/unloaded using a network linkORA-31679: Table data object" HIS "." COM_EBIS_UPDATE_LOG "has long columns, and longs can not be loaded/unloaded using a network linkORA-31679: Table data object" HIS "." COM_SQL "has long columns, and longs can not be loaded/unloaded using a network link. . Exported "SYJJHIS". "PHA_COM_STORAGE" 897.5 KB 5374 rowsORA-31679: Table data object "HIS". "CHK_COM_SQL" has long columns, and longs can not be loaded/unloaded using a network linkORA-31679: Table data object "HIS". "COM_SQL_PPC" has long columns, and longs can not be loaded/unloaded using a network linkORA-31679: Table data object "HIS". "DCP_COM_SQL" has long columns, and longs can not be loaded/unloaded using a network link
2. Official documents
DataPump Import Of Tables Containing LONG Columns Using NETWORK_LINK Raises The Error ORA-31679 (document ID 1470331.1) 3, solution 1) expdp export locally, then scp transfer, and then impdp import 2) Direct exp export
Here, because the data file is only a few dozen gigabytes, only exp export is used directly. However, the 11g version is still recommended that you use expdp to back up your data.