Network card pits encountered by jmeter remote distribution execution
Previously, distributed remote stress testing went well, but this time it was impossible to get the response data from the remote press, and there was no error in checking the log.
Problem description:
Configure the IP value and port number of each press in the remote_hosts= of the jmeter.properties file, start the jmeter control machine jmeter.bat and the remote press jmeter-server.bat, select the jmx script to be executed, and "start all remotely" in "run". The remote end shows that it has started and ended, but the control side does not receive any response information.
"Remote engines have been started" is displayed in the jmeter log of the control side, and it is always prompted when doing other operations on jmeter GUI.
And jmeter has been stuck there and lost its response.
After finding the corresponding error reporting problem on the Internet, follow the prompts, and sure enough, the problem has been solved.
Solution:
Due to the installation of a virtual machine Oracle VM VirtualBox before this machine, a virtual network card has been started all the time. Disable it in the adapter when a problem is found, as shown below:
After disabling, starting jmeter-server.bat again shows the correct ip address. In order to prevent the press from having multiple network cards, it is recommended to disable the network cards that do not work. Execute the remote press again, everything OK.
At this point, the problem has been solved.