Get the App
SLTechnology News&Howtos  ›  Database  › 

RAC modifies parameter DB_FILES

Shulou Source: shulou.com Published: 2022-06-01 17:39:50 10月04日 Update

This blog focuses on the steps of how to modify the parameters under RAC in a production environment, which is a little different from a single instance.

DB_FILES defines the number of data files in the oracle data. When the number of data files exceeds the value set by this parameter, the error ORA-00059 will be reported.

Solution:

Show parameter db_files;-View the value of the current setting

Sqlplus / as sysdba

Larger value of alter system set db_files= scope=spfile

Shutdown immediate

Startup

Description:

The size of the value set by this parameter does not affect efficiency, but simply controls the number of data files.

The steps to modify this parameter in RAC production environment are as follows:

(1) View the parameter value in any node first.

SQL > show parameter db_files

NAME TYPE VALUE

-

Db_files integer 200

Execute on any node, where sid='*' means to take effect on all instances

SQL > alter system set db_files=350 scope=spfile sid='*'

Stop all the monitoring on all nodes

[grid@RAC1 ~] $srvctl stop listener

[grid@RAC1 ~] $srvctl status listener

Listener LISTENER is enabled

Listener LISTENER is not running

Execute the Kill LOCAL=NO process on all nodes

All external links to Kill

Ps-ef | grep LOCAL=NO | grep-v grep | awk'{print $2}'| xargs kill-9

(5) execute on all nodes

Zhengzhou Infertility Hospital: http://jbk.39.net/yiyuanzaixian/zztjyy/

SQL > shutdown immediate

Database closed.

Database dismounted.

ORACLE instance shut down.

(6) start the library in order. Do not start another library before it has been started, otherwise the following error will occur

ORA-01105: mount is incompatible with mounts by other instances

ORA-01174: DB_FILES is 350 buts needs to be 320 to be compatible

Tags: Parameters nodes data number files instances steps environment errors production admirals infertility methods hospitals blogs just size efficiency time process Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno MySQL Shulou Information NVidia Apple Xiaomi