Get the App
SLTechnology News&Howtos  ›  Internet Technology  › 

Frequently asked questions about the use of loadrunner11 (constantly sorting out)

Shulou Source: shulou.com Published: 2022-06-03 06:46:52 10月03日 Update

Frequently asked questions about loadrunner11 usage

Script recording is empty

1. Check whether the agreement is correct

two。 Close extraneous browsers and set IE or Firefox as the default browser

3. Recording options-> Network-> Port Mapping-> capture level, modified to: socket level and winnet level data

Execution prompt timeout error

The general prompt timeout error is caused by too much concurrency pressure and the server is too busy to respond to the client's request in time.

Error-27728: Step download timeout (120seconds) has expired when downloading non-resource (s)

1. The default timeout of HTTP protocol is 120s. The client sends a request to the server. If the server does not return a result for more than 120s, a timeout error occurs.

two。 Modify the values of Run-Time Settings-> Internet Protocol:Preferences-> options-> Step download time, and HTTP-request connect timeout or HTTP-request receive

Error-27796: Failed to connect to server www.baidu.com:80: [10048]

1. In the registry HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameters, there are two key values: TcpTimedWaitDelay and MaxUserPort

2. The default value of TcpTimedWaitDelay should be 30s, so here, reduce this value to 5s (adjust as needed).

3. Increase the MaxUserPort by-> 65534 (if this value is not the maximum).

Note: if a small number of users have this problem, it may be a program problem; if a large number of users have this problem, the system may not be able to support so much concurrency.

Error-27979: Requested from not found or web_submit_form highest severity level was "ERROR", 0 body bytes,0 header bytes.

1. The selected recording script mode is incorrect.

1) Recording Options-> Internet Protocol-> Recording-> Recording Level is HTML-based script

2) Click HTML Advanced, and select Script Type as A script containing explicit

3) choose to use URL_based script mode to record scripts.

two。 Caused by no association or incorrect association boundary.

How to keep running after the execution error to ensure uninterrupted stress testing

Run-time Settings-> General-> Miscellaneous. For the configuration of Error Handling, check "Continue on error" to allow virtual users to continue running due to errors.

Tags: Errors problems server user script service selection stress customer mode browser association prompt browse run FAQ maximum busy two Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Shulou Tech Info Xiaomi Microsoft Linux vpn