[giant Sequoia Database SequoiaDB] Giant Sequoia Tech | four steps, quick
1. Background
SequoiaDB Giant Sequoia Database is a financial-level distributed database, including distributed NewSQL, distributed file system and object storage, and high-performance NoSQL storage modes, corresponding to distributed online transactions, unstructured data and content management, as well as massive data management and high-performance access scenarios.
Clusters generally use three copies to ensure data security. If there are node failures or cluster anomalies caused by hardware failures in the cluster, the database administrator should analyze and diagnose the system to ensure that the cluster works normally and will not affect the normal use of users. This article will share with you the basic diagnostic methods of SequoiaDB database.
Database cluster diagnosis
1) determine the installation path of SequoiaDB
If you are new to the new SequoiaDB environment, you can view the database installation path through the cat / etc/default/sequoiadb command.
Cat tc/default/sequoiadb
NAME=sdbcm
SDBADMIN_USER=sdbadmin
INSTALL_DIR=/opt/sequoiadb
INSTALL_DIR is the path where SequoiaDB is installed.
2) list cluster node information
[inspection method]
Switch to the database installation user (default is sdbadmin user) and view the node information and all nodes.
$sdblist-l
$sdblist-t all
From left to right, there are SvcName (node name), Role (role name is divided into cataloging node, coordination node and several nodes), PID (process number), GID, NID, PRY (whether it is the main node or not), GroupName (group name), StartTime (startup time), DBPath (installation path) and so on. This information is of great help to the analysis of location problems.
[abnormal situation]
Check and find that the node is not started, the node startup error is reported, and the node is unable to start.
[handling method]
If the data node 11820 node is not started, you should first try to restart the node and restart it using the sdbstart-p 11820 command. Find the log information in the node installation directory, which is ${DBPath} / diaglog/ sdbdiag.log.
[case study]
Execute sdbstart-p 11820 startup node to report an error.
$sdbstart-p 11820
11820: 69 bytes out== >
Db role: data_test error
Failed resolving arguments (error=-6), exit