Get the App
SLTechnology News&Howtos  ›  Database  › 

What is the reason why the Oracle Listener service cannot be started?

Shulou Source: shulou.com Published: 2022-05-31 16:57:13 10月03日 Update

This article introduces you what is the reason why Oracle Listener service can not be started, the content is very detailed, interested friends can refer to, hope to help you.

Recently, I changed the project team, and recently I suddenly found that Oracle Listener could not be started. In the past, it was found that the reason why it could not be started was that the previous registry was not deleted after reinstalling Oracle, so that the command file to start the service by default still pointed to the previous location, so it could not be started, but the Oracle of this computer was installed only once.

Yesterday, I suddenly found that the Host in the listener.ora file is still configured with the previous computer name, because the local Oracle has not been started after changing the project team, so I can't start it this time. After changing the hostname in the configuration, everything is normal.

Oracle uses the hostname for local settings, not IP, and IP for remote addresses.

Specific location: oracle/product/10.1.0/db_1/NETWORK/ADMIN/listener.ora

-

LISTENER =

(DESCRIPTION_LIST =

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = IPC) (KEY = EXTPROC))

)

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP) (HOST = computer name) (PORT = 1521))

)

)

)

This is the reason why the Oracle Listener service can not be started. I hope the above content can be helpful to you and learn more knowledge. If you think the article is good, you can share it for more people to see.

Tags: Reason service host location content name file more computer project project team help configuration good interest command address boy partner point to Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno vpn MariaDB Apple OPPO Reno Docker