The process of making the service unavailable due to the abnormal growth of the jenkins log
Today, I found that mysql service reported 28 errors (28 errors are caused by insufficient disk space). Check the disk space usage of the server and find that the log file catalina.out under the tomcat directory is abnormal. The error is as follows:
question: [DNSQuestion@251754929 type: TYPE_IGNORE index 0, class: CLASS_UNKNOWN index 0, name: ]
question: [DNSQuestion@515297623 type: TYPE_IGNORE index 0, class: CLASS_UNKNOWN index 0, name: ]
question: [DNSQuestion@1774851545 type: TYPE_IGNORE index 0, class: CLASS_UNKNOWN index 0, name: ]
question: [DNSQuestion@72039330 type: TYPE_IGNORE index 0, class: CLASS_UNKNOWN index 0, name: ]
After Baidu, you need to add in the catalina.sh script file in tomcat's bin directory:
export JAVA_OPTS="-Dhudson.DNSMultiCast.disabled=true -Dhudson.udp=-1"
The above problem was solved after restart.