How to deal with ORA-00313 ORA-00312 redo log error report
Editor to share with you how to deal with ORA-00313 ORA-00312 redo log errors, I believe most people do not know much about it, so share this article for your reference, I hope you can learn a lot after reading this article, let's go to know it!
1. The front desk starts the database to report an error.
SQL > alter database open
Alter database open
*
ERROR at line 1:
ORA-03113: end-of-file on communication channel
Process ID: 18809
Session ID: 1 Serial number: 50801
2. The background alter$ORACLE_SID.log reports an error
Alter database open
2017-09-16T21:38:38.117453+08:00
Ping without log force is disabled:
Instance mounted in exclusive mode.
Endian type of dictionary set to little
2017-09-16T21:38:38.136378+08:00
Errors in file / u01/app/oracle/diag/rdbms/orcl/orcl/trace/orcl_lgwr_18769.trc:
ORA-00313: open failed for members of log group 7 of thread 1
ORA-00312: onlinelog 7 thread 1:'/ u01 apprentice.oracle.oradata; orcl; onlinog.redolog12.log'
ORA-27037: unable to obtain file status
Linux-x86_64 Error: 2: No such file or directory
Additional information: 7
ORA-00312: onlinelog 7 thread 1:'/ u01 apprentice.oracle.oradata; orcl; onlinelog; redolog8.log'
ORA-27037: unable to obtain file status
Linux-x86_64 Error: 2: No such file or directory
Additional information: 7
2017-09-16T21:38:38.136457+08:00
Errors in file / u01/app/oracle/diag/rdbms/orcl/orcl/trace/orcl_lgwr_18769.trc:
ORA-00313: open failed for members of log group 7 of thread 1
ORA-00312: onlinelog 7 thread 1:'/ u01 apprentice.oracle.oradata; orcl; onlinog.redolog12.log'
ORA-27037: unable to obtain file status
Linux-x86_64 Error: 2: No such file or directory
Additional information: 7
ORA-00312: onlinelog 7 thread 1:'/ u01 apprentice.oracle.oradata; orcl; onlinelog; redolog8.log'
ORA-27037: unable to obtain file status
Linux-x86_64 Error: 2: No such file or directory
Additional information: 7
2017-09-16T21:38:38.137207+08:00
Errors in file / u01/app/oracle/diag/rdbms/orcl/orcl/trace/orcl_ora_18809.trc:
ORA-00313: open failed for members of log group 1 of thread
ORA-00312: onlinelog 7 thread 1:'/ u01 apprentice.oracle.oradata; orcl; onlinelog; redolog8.log'
ORA-00312: onlinelog 7 thread 1:'/ u01 apprentice.oracle.oradata; orcl; onlinog.redolog12.log'
2017-09-16T21:38:38.152526+08:00
TT00: Gap Manager starting (PID:19017)
2017-09-16T21:38:38.168038+08:00
USER (ospid: 18809): terminating the instance due to error
2017-09-16T21:38:38.253720+08:00
System state dump requested by (instance=1, osid=18809), summary= [abnormal instance termination].
System State dumped to trace file / u01/app/oracle/diag/rdbms/orcl/orcl/trace/orcl_diag_18751_20170916213838.trc
2017-09-16T21:38:38.393632+08:00
Dumping diagnostic data in directory= [CDMP _ 20170916213838], requested by (instance=1, osid=18809), summary= [abnormal instance termination].
2017-09-16T21:38:39.702685+08:00
Instance terminated by USER, pid = 18809
How to handle it:
Clear archive log
Alter database clear unarchived logfile group 7
-- alter database clear unarchived logfile group 2
-- alter database clear unarchived logfile group 3
Alter database open
The above is all the contents of the article "how to deal with errors in the ORA-00313 ORA-00312 redo log". Thank you for reading! I believe we all have a certain understanding, hope to share the content to help you, if you want to learn more knowledge, welcome to follow the industry information channel!