Get the App
SLTechnology News&Howtos  ›  Database  › 

What about the newly built mysql login error mysql Segmentation fault

Shulou Source: shulou.com Published: 2022-05-31 15:28:19 10月02日 Update

Editor to share with you the newly built mysql login error mysql Segmentation fault how to do, I believe that most people do not understand, so share this article for your reference, I hope you will learn a lot after reading this article, let's go to know it!

Environment introduction:

Operating system: CentOS Linux release 7.3.1611

192.168.0.44

192.168.0.45

Mysql version: mysql-5.6.38

After the source code installation is complete, try to log in, and the error is as follows

[root@localhost bin] # mysql

Enter password:

Welcome to the MySQL monitor. Commands end with; or\ g.

Your MySQL connection id is 8

Server version: 5.6.24 Source distribution

Copyright (c) 2000, 2015, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its

Affiliates. Other names may be trademarks of their respective

Owners.

Mysql Segmentation fault (core dumped)

= solution =

In the source package, edit the file / media/mysql-5.6.38/cmd-line-utils/libedit/terminal.c (the path where the mysql installation package is located)

Comment on the line char buf [TC _ BUFSIZE] in the terminal_set method, and then change area = buf; to area = NULL

After the change, the red part is as follows

Protected int

Terminal_set (EditLine el, const char * term)

{

Int i

/ * char buf [TC _ BUFSIZE]; * /

Char * area

Const struct termcapstr * t

Sigset_t oset, nset

Int lins, cols

-- phpfensi.com

(void) sigemptyset & nset)

(void) sigaddset (& nset, SIGWINCH)

(void) sigprocmask (SIG_BLOCK, & nset, & oset)

Area = NULL

Then recompile it.

[root@ora101 media] # cd mysql-5.5.37

[root@ora101 mysql-5.6.38] # cmake. \

-DCMAKE_INSTALL_PREFIX=/usr/local/mysql\

-DSYSCONFDIR=/etc\

-DDEFAULT_CHARSET=utf8\

-DDEFAULT_COLLATION=utf8_general_ci\

-DEXTRA_CHARSETS=all\

-DENABLED_LOCAL_INFILE=1

[root@ora101 mysql-5.6.38] # make

[root@ora101 mysql-5.6.38] # make install

Problem solved.

The above is all the contents of the article "what to do with the newly built mysql login error mysql Segmentation fault". Thank you for reading! I believe we all have a certain understanding, hope to share the content to help you, if you want to learn more knowledge, welcome to follow the industry information channel!

Tags: Articles how to do login content method source code operating system one line not much most location files more comments versions environment knowledge systems red industry Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno NVidia Docker Apple OPPO Reno vpn