Get the App
SLTechnology News&Howtos  ›  Database  › 

Gcadmin returns GC_AIS_ERR_LIBRARY

Shulou Source: shulou.com Published: 2022-06-01 05:03:45 10月05日 Update

Phenomenon description

Execute gcadmin on one of the nodes in the cluster and return GC_AIS_ERR_LIBRARY, as shown in the following figure.

Cause analysis

When this problem occurs, on the one hand, you need to check whether the current user has permission to modify the / dev/shm directory, and on the other hand, check that the server's / dev/shm directory is full.

Execute the strace gcadmin command and see the information shown in the following figure at the end.

Then look up to the system call with the last error. If the keyword "Permission denied" appears, it indicates that the failure of gcadmin execution is caused by no permissions, as shown in the following figure.

If the "No space left on device" keyword appears, it means that the server's / dev/shm directory is full, as shown in the following figure.

In addition, execute the df-ahT command, and if the / dev/shm directory Use% is 100%, the / dev/shm directory is full.

Solution.

If it is "Permission denied", give the current user read and write access to the / dev/shm directory.

If "No space left on device" is caused by too many concurrency, check the number of concurrency and reduce the number of concurrency.

Tags: Directory permission check occupied key keyword command server user service party information method cause analysis on the other hand quantity phenomenon system followed by Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno MariaDB vpn NVidia Redmi Docker