The pit encountered by hadoop
Pit 1:STARTUP_MSG: host = java.net.UnknownHostException: slavel3: slavel3: domain name resolution failed temporarily
Answer: I / etc/hosts has the right configuration.
I / etc/sysconfig/network is misconfigured. Can you tell the difference between slave13 and slavel3? One is the letter L. One is the number 1.
After modifying / etc/sysconfig/network, then # hostname slave13. Let it take effect temporarily. Or you'll have to restart it.
Pit 2:java.net.BindException:Address already in use
I solved it through the following article:
The DataNode service of a node in the cluster cannot be started (java.net.BindException:Address already in use error reported)-Xiaohe 001-blog Park
Http://www.cnblogs.com/xiaohe001/p/6427413.html
Pit 3: an error was reported when uploading files:
Then, I looked at datanode's log, and as a result, pit 2 was led out.
After solving the pit 2, it leads to the pit 1.