Get the App
SLTechnology News&Howtos  ›  Database  › 

The first instance cannot be started after the second database instance is created on 12c

Shulou Source: shulou.com Published: 2022-06-01 05:36:50 10月01日 Update

12.2.0.1 is installed on Windows 10, and the first instance, orcl, is installed as a non-empty database. After normal use, shut down the instance.

Create a second database instance, zlcdb, and create a container database. After you can use it normally, close the instance.

Start the first instance orcl again, and set the environment variable first:

Set oracle_sid=orcl

Then log in to the empty instance:

Sqlplus sys/his as sysdba

Execute startup again

Prompt error

ORA-01078: failure in processing system parameters

LRM-00109: could not open parameter file'C:\ app\ yonker\ virtual\ product\ 12.2.0\ dbhome_1\ database\ initORCL.ora'

Check the database directory for the SPFile file SPFILEORCL.ORA

Initorcl.ora should not be prompted for this Pfile file, it should be SPFile priority.

Puzzled, try to copy the original pfile file: init.ora.2192018101632 from the C:\ app\ yonker\ virtual\ admin\ orcl\ pfile directory

Copy it to the database directory and rename it to initOrcl.ora

If you start it again, it's the same error.

Didn't you recognize the spfile file? Could it be the reason for the permission?

Therefore, after comparing the spfile files of the two instances, it is found that there is indeed a problem with the permissions of spfileorcl.ora.

The permissions of spfileorcle.ora include the permissions of an OracleServiceOrcl service.

However, the permissions of spfilezlcdb.ora are those of the group ORA_OraDB12Home1_SVCACCTS.

Then go to the computer-managed user group to see that the members of the ORA_OraDB12Home1_SVCACCTS group include a number of services such as OracleServiceOrcl services.

Therefore, the OracleServiceOrcl service with the permission of spfileorcle.ora is deleted, and after the permission of ORA_OraDB12Home1_SVCACCTS group is added, the orcl instance is enabled successfully.

12C added a series of operating system user groups, including: ORA_OraDB12Home1_SVCACCTS,ORA_OraDB12Home1_DBA, etc.

And put forward the concept of virtual account, which needs further study.

Tags: Instances permissions files services data databases directories again users user groups errors prompts success puzzling operating system two reasons variables multiple Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno OPPO Reno Redmi Docker Microsoft Shulou Information