Get the App
SLTechnology News&Howtos  ›  Database  › 

Mysql 5.6Multiinstance mysqld_multi stop failed to shut down the database

Shulou Source: shulou.com Published: 2022-06-01 16:40:00 10月04日 Update

Description

According to the needs of the business, from the perspective of rational use of hardware resources, production database preparation part of the business to run multiple instances, encountered a small problem in the process of testing, record it.

2.vi / etc/my.cnf

[mysqld_multi] mysqld=/usr/bin/mysqld_safemysqladmin=/usr/bin/mysqladminuser = rootpassword = rootlog=/tmp/multi.log..

3. Error message

# mysqld_multi stop 3307-3307 stands for GNR Group numbers

When shutting down the database, the user, password, and permissions are all OK.

Warning: Using a password on the command line interface can be insecure./usr/bin/mysqladmin: connect to server at 'localhost' failederror:' Access denied for user 'root'@'localhost' (using password: YES)' mysqld_multi log file version 2.16; run: Wed Dec 14 15:31:32 2016

4. Treatment method

# which mysqld_multi/usr/bin/mysqld_multi# vi / usr/bin/mysqld_multimy $com= join', 'my_print_defaults', @ defaults_options, $group; replace with: my $com= join', 'my_print_defaults-slots, @ defaults_options, $group

5. Re-execution successful

# mysqld_multi stop 3307# mysqld_multi reportReporting MySQL serversMySQL server from group: mysqld3307 is not running

The mainframe server resources of most companies are relatively free, especially the database server, how to ensure the normal business for the company

Saving money is a problem that needs to be considered, and all departments need to consider it. If you have money, you will live the life of the rich; if you have no money, you will live the life of ordinary people.

In other words, the business pressure has come up, and it is likely that the company's ability to make money has also come up, and it is not too late to make adjustments at that time, step by step, so is the architectural design. Continuous improvement and evolution is reasonable.

Tags: Business data database company server resource problem service life instance ordinary rich successful step by step then continuously for company host representative information Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Shulou Technology vpn MySQL Linux MariaDB