Get the App
SLTechnology News&Howtos  ›  Internet Technology  › 

How to solve kafka error larger than available brokers

Shulou Source: shulou.com Published: 2022-06-01 12:57:33 10月02日 Update

How to solve the kafka error larger than available brokers? in view of this problem, this article introduces the corresponding analysis and solution in detail, hoping to help more partners who want to solve this problem to find a more simple and feasible way.

This error in kafka will trigger in many places:

CDH continues testing. I ran into this comparative pit today.

Error while executing topic command: replication factor: 2 larger

Kafka-topics-create-topic event_topic-zookeeper x.x.x.x-replication-factor 2-partitions 3-config retention.ms=600000

And then reported a lot of mistakes:

Error while executing topic command: replication factor: 2 larger than available brokers: 0

20-04-16 11:01:15 ERROR admin.TopicCommand$: org.apache.kafka.common.errors.InvalidReplicationFactorException: replication factor: 2 larger than available brokers: 0

I am puzzled by my thoughts.

Then I went to see config.

It is found that the zookeeper.connect of config does not write ip but the host name. So change the hostname on the command line.

Unexpectedly ok.

This is the answer to how to solve the problem of kafka error larger than available brokers. I hope the above content can be of some help to you. If you still have a lot of doubts to be solved, you can follow the industry information channel for more related knowledge.

Tags: Errors questions hosts more help answers easy easy content commands places piles guys partners methods knowledge articles industries information Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno MySQL Linux macOS OPPO Reno Apple