MySQL5.6 CREATE TABLE source code analysis
Previous versions of MySQL5.6, DDL, were non-atomic. That is to say, for composite DDL, such as DROP TABLE T1, T2; if server crash is encountered during execution, table T1 may be dropped by DROP, but T2 will not be dropped by DROP. Even a DDL, such as CREATE TABLE T1 (an int), may result in incomplete table creation in the case of server crash, and may leave .frm or .ibd files in the event of table creation failure.
As can be seen from the principle flow chart, create table first creates the .frm file, then calls ha_create_table to create the ibd file, and exits if the creation is successful, otherwise the previously created frm file will be deleted. But there is a problem here. If the server dies after creating the frm file, then the frm file is created successfully, but the ibd file is not created. This is the consequence of the non-atomicity of DDL.