SQL Server 2017 AlwaysOn on Linux configuration and maintenance (5)
2.2.1 three synchronous copies
This configuration contains three synchronous copies. By default, it provides high availability and data protection. It can also provide read scaling.
An availability group with three synchronous copies can provide read scaling, high availability, and data protection. The following table describes the available sexual behavior.
Read Zoom
& High availability
Data protection
Data protection
REQUIRED_SYNCHRONIZED_SECONDARIES_TO_COMMIT=
0
1 *
two
Primary copy interrupt
Manual failover. May result in data loss. The new master copy is R / w.
Automatic failover. The new master copy is R / w.
Automatic failover. The new primary database is not available for user transactions until the previous primary copy is restored and added to the availability group as a secondary.
A secondary copy is interrupted
Mainly R / w. If the master does not have automatic failover, it will fail.
Mainly R / w. If the master does not have automatic failover, it will also fail.
User transactions that are not available in the primary database.
* default value