Get the App
SLTechnology News&Howtos  ›  Database  › 

ORA-00221 ORA-00206 ORA-00202 ORA-27041 error

Shulou Source: shulou.com Published: 2022-06-01 10:48:25 10月03日 Update

SUSE Linux 11+oracle 11.2.0.3 environment, / oradata mounted on storage

A controller failure restart is stored tonight, but the server has made a dual path. The storage controller restart does not affect the operating system to recognize the / oradata file system on storage, that is, the file system is accessed normally at the moment the controller restarts.

However, oracle automatically shuts down and re-startup with the following error:

SQL > startup

ORACLE instance started.

Total System Global Area 1.5667E+10 bytes

Fixed Size 2243752 bytes

Variable Size 7851737944 bytes

Database Buffers 7784628224 bytes

Redo Buffers 28151808 bytes

ORA-00221: error on write to control file

ORA-00206: error in writing (block 1, # blocks 1) of control file

ORA-00202: control file:'/ oradata/orcl/control01.ctl'

ORA-27041: unable to open file

Linux-x86_64 Error: 30: Read-only file system

Additional information: 3

See this error first determine that the storage controller restart the moment / oradata may be interrupted, and then instantly cut to another controller, the control file control01.ctl is damaged, there are a total of three control files, one of which control03.ctl is placed on the server's local hard disk, so I want to copy the damaged control01.ctl on control03.ctl replacement / oradata.

Control01.ctl will be backed up first, but the error is that the read-only file cannot be modified.

Oracle@db1:/oradata > cd orcl/

Oracle@db1:/oradata/orcl > ls

Abctest control01.ctl redo01.log redo02.log redo03.log redo04.log redo05.log redo06.log redo07.log sysaux01.dbf system01.dbf temp01.dbf undotbs01.dbf users01.dbf

Oracle@db1:/oradata/orcl > mv control01.ctl control01.ctl.bak

Mv: cannot move `control01.ctl' to `control01.ctl.bak': Read-only file system

Use the ls command to check that control01.ctl obviously has read and write access to oracle users.

Oracle@db1:/oradata/orcl > ll

Total 1816884

Drwxr-xr-x 2 oracle oinstall 4096 Oct 15 10:56 abctest

-rw-r- 1 oracle oinstall 17154048 Oct 17 22:39 control01.ctl

-rw-r- 1 oracle oinstall 52429312 Oct 17 22:37 redo01.log

-rw-r- 1 oracle oinstall 52429312 Oct 17 22:38 redo02.log

-rw-r- 1 oracle oinstall 52429312 Oct 17 22:39 redo03.log

-rw-r- 1 oracle oinstall 52429312 Oct 15 16:07 redo04.log

-rw-r- 1 oracle oinstall 52429312 Oct 15 16:07 redo05.log

-rw-r- 1 oracle oinstall 52429312 Oct 15 16:08 redo06.log

-rw-r- 1 oracle oinstall 52429312 Oct 15 16:08 redo07.log

-rw-r- 1 oracle oinstall 629153792 Oct 17 22:37 sysaux01.dbf

-rw-r- 1 oracle oinstall 744497152 Oct 17 22:37 system01.dbf

-rw-r- 1 oracle oinstall 30416896 Oct 17 22:37 temp01.dbf

-rw-r- 1 oracle oinstall 94380032 Oct 17 22:37 undotbs01.dbf

-rw-r- 1 oracle oinstall 5251072 Oct 17 22:37 users01.dbf

It is strange that oracle locks control01.ctl, but the oracle instance is closed at this time.

Finally, I restarted the server operating system, and then I could startup directly without restoring control01.ctl.

That's weird?

Tags: Control controller file storage system server service operating system obvious three commands backup instance failure permissions environment user hard disk say path Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Linux OPPO Reno Shulou Tech Info Shulou Information vpn