Get the App
SLTechnology News&Howtos  ›  Development  › 

What if the FastCGI process exits unexpectedly and causes 500 errors?

Shulou Source: shulou.com Published: 2022-06-03 18:12:38 10月03日 Update

This article introduces the relevant knowledge of "what to do when the FastCGI process exits unexpectedly and causes 500errors". In the operation of actual cases, many people will encounter such a dilemma. Next, let the editor lead you to learn how to deal with these situations. I hope you can read it carefully and be able to achieve something!

On a new server, install a new website, which was previously placed on only one website. It is a non-integrated environment configured by the server provider.

A new site was added and the path was worked out, but a 500 error occurred during the visit. The hint seems to be a problem with php, but the previous website, running discuz, everything is fine, add a new site and report an error. It is the same error to execute with the phpinf statement.

After a period of Baidu, the solution is as follows.

Open iis, Application Pool. Select the settings application pool default settings on the right.

In the pop-up window, find the logo and click the small square on the right.

Change the value to LocalSystem. Restart IIS to solve the problem.

This is the end of the content of "what to do if the FastCGI process exits unexpectedly?" Thank you for your reading. If you want to know more about the industry, you can follow the website, the editor will output more high-quality practical articles for you!

Tags: Website error accident what to do process content right application more server knowledge program application service utility achievement and then dilemma reality situation Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno MySQL Shulou Technology Docker Microsoft OPPO Reno