How to solve the problem of unsuccessful max_allowed_packet modification in mysql5.7
I don't know if you have any knowledge about how to solve the problem of unsuccessful max_allowed_packet modification in mysql5.7. Today, I'm here to tell you a little bit about it. If you are interested, let's take a look at the body. I believe you will gain something after reading how to solve the unsuccessful modification of max_allowed_packet in mysql5.7.
# Error querying database. Cause: com.mysql.jdbc.PacketTooBigException: Packet for query is too large (2010 > 1024). You can change this value on the server by setting the max_allowed_packet' variable.
This error is obviously because the max_allowed_packet setting is a little small. Then log in to the database
Sure enough, it's a little small.
Then check that the configuration file is normal, and communicate with the customer that the configuration file has already been written, which obviously does not work to restart the library. In order to minimize the impact on the business, there is no restart test and a communication record is attached.
Then set globle, the test is futile. "there is a picture and there is a truth."
We have no choice but to go to the official website to find information. The solution given on the official website is to add start-up parameters.
So find the startup script of mysql and paste the startup parameters
Then communicate with the customer to restart the database.
Then show variables like'% pac%'; Hey, it's done!
Make a note of it, don't hate it if you like it.
After reading the mysql5.7 max_allowed_packet modification is not successful how to solve this article, what do you think? If you want to know more about it, you can continue to follow our industry information section.