Oracle11g ORACLE not available
After making something for my roommate with Oracle, I closed the database directly with shutdown abort, sent him the file created under the tablespace, then dropped the original file, and then reconnected to Oracle.
First, log in to sqlplus / nolog
SQL > conn system enter password: ERROR:ORA-01034: ORACLE not availableORA-27101: shared memory realm does not exist process ID: 0 session ID: 0 serial number: 0
Startup appears:
SQL > startupORA-01031: insufficient privileges
Then there is Google, Baidu, which is used on the command line:
Sqlplus "sys/password as sysdba"
Connected to an idle routine. After that, startup, the database was started successfully with errors
The SQL > startupORACLE routine has been started. Total System Global Area 1670221824 bytesFixed Size 2176328 bytesVariable Size 1006635704 bytesDatabase Buffers 654311424 bytesRedo Buffers 7098368 bytes database loaded. ORA-01157: unable to identify / lock data file 6-see DBWR trace file ORA-01110: data file 6: d:\ MYTBS1.DBF'
Seeing here, I know that it was I who deleted the tablespace file that led to the different configuration when the database was opened, so I can't start it. After I retrieve the file, everything will be ok.