Summary description of Last_SQL_Errno error codes for MySQL master-slave replication
1005: failed to create table
1006: failed to create database
1007: database already exists, failed to create database
1008: database does not exist, failed to delete database
1009: failure to delete database due to failure to delete database file
1010: failure to delete database due to failure to delete data directory
1011: failed to delete database file
1012: unable to read records in system table
1020: the record has been modified by another user
1021: there is not enough space left on the hard disk. Please increase the available space on the hard disk.
1022: duplicate keyword, failed to change record
1023: error occurred during shutdown
1024: read file error
1025: error occurred while changing name
1026: file write error
1032: record does not exist
1036: the datasheet is read-only and cannot be modified
1037: the system is out of memory, please restart the database or restart the server
1038: insufficient memory for sorting, please increase the sort buffer
1040: the maximum number of connections to the database has been reached. Please increase the number of available connections to the database.
1041: out of system memory
1042: invalid hostname
1043: invalid connection
1044: the current user does not have access to the database
1045: unable to connect to the database, wrong username or password
1048: field cannot be empty
1049: database does not exist
1050: datasheet already exists
1051: datasheet does not exist
1054: field does not exist
1065: invalid SQL statement, SQL statement is empty
1081: Socket connection cannot be established
1114: the datasheet is full and cannot hold any records
1116: too many data tables are open
1129: there is an exception in the database. Restart the database.
1130: failed to connect to the database, do not have permission to connect to the database
1133: database user does not exist
1141: the current user does not have access to the database
1142: the current user does not have access to the data table
1143: the current user does not have access to fields in the data table
1146: datasheet does not exist
1147: no user access to the datasheet is defined
Syntax error of 1149:SQL statement
1158: network error, read error, please check the network connection status
1159: network error, read timeout, please check the network connection status
1160: network error, write error, please check the network connection status
1161: network error, write timeout, please check the network connection status
1062: duplicate field value, failed to enter the database
1169: duplicate field value, failed to update record
1177: failed to open datasheet
1180: failed to commit transaction
1181: failed to roll back the transaction
1203: the maximum number of connections between the current user and the database has reached the database. Please increase the number of available database connections or restart the database.
1205: lock timeout
1211: the current user does not have permission to create a user
1216: failed to check foreign key constraints and update child table records
1217: foreign key constraint check failed, delete or modify master table record failed
1226: the current user has used more resources than allowed, please restart the database or restart the server
1227: insufficient permissions, you are not authorized to perform this operation
The 1235:MySQL version is too low to have this feature.