CUCM upgrade Times error & the solution of quot;Upgrades are prohibited during Licensing Grace Period"
When I was upgrading CUCM a few days ago, I encountered the following error
"Upgrades are prohibited during Licensing GracePeriod", after searching for information and groping on its own, found that there are two ways to solve this problem:
Problem phenomenon:
After Disaster Recovery System (DRS) backup is done onthe old server, we DRS restore all the data into the newly replaced server. Thelicense file for old server is valid for 30 days.
During license grace period, you can not proceed due tothe upgrade error message "Upgrades are prohibited during License GracePeriod".
If this error message is seen during a jump upgrade to9.1 (2) see CSCuj10105.
Solution:
Method 1:
This method is the solution given by Cisco, as follows:
If license is uploaded before DRS restore then use thefollowing steps to correct the state of licensing on the system:
1. Remove the rehosted (new) license files using clicommond "file delete xxx.lic"
2. Restart license manager.
3. Re-upload the rehosted (new) license files.
Method 2:
Now that we know clearly that this error is due to a problem with license, can we import a demo license? The answer is yes; the test passed!