Tomcat8.5 remotely accesses manager pages
Since the company deploys a new website, it is OK to test it locally, but it will report an error if it is uploaded to the Ali cloud server and tested again, so you need to open the remote access manager page and let the developer upload and deploy the test himself.
Online search circle, unexpectedly there is no very clear manager page to open the tutorial, their own search found the answer.
Direct remote login to the manager page will prompt you to change the context.xml file under the manger project if the address is rejected. This file is in the tomcat/webapps/manager/MATA-INF/ folder. The default content is:
There is an attribute under the context tag that is
Org.apache.catalina.valves.RemoteAddrValve
This is to set remote filtering properties, this property has two attribute values can be set, allow and deny, which is equivalent to access whitelist and blacklist, also equivalent to ACL access filtering, allow and deny values can be written IP with regular expressions to match, can also write domain names and computer names.
Comment out this attribute directly and you can access the manager page directly. Of course, I do not recommend this. The user name and password of the manager page can be easily cracked, causing others to upload projects or other things at will, so it is best to have filtering if there is no special need.