Get the App
SLTechnology News&Howtos  ›  Internet Technology  › 

How to solve the c3p0 pool problem of tomcat reporting errors because database users are locked

Shulou Source: shulou.com Published: 2022-06-01 18:39:20 10月01日 Update

How to solve the c3p0 pool problem of reporting errors in tomcat because database users are locked? in view of this problem, this article introduces the corresponding analysis and solutions in detail, hoping to help more partners who want to solve this problem to find a more simple and feasible method.

C:\ Program Files\ Intel\ Intel (R) Management Engine Components\ IPT;C:\ Users\ comsys\ AppData\ Local\ Microsoft\ WindowsApps;;.

Java.specification.name=Java Platform API Specification

Java.class.version=50.0

Sun.management.compiler=HotSpot 64-Bit Tiered Compilers

Os.version=6.2

Org.apache.catalina.startup.ContextConfig.jarsToSkip=

User.home=C:\ Users\ comsys

Catalina.useNaming=true

User.timezone=Asia/Shanghai

Java.awt.printerjob=sun.awt.windows.WPrinterJob

File.encoding=GBK

Java.specification.version=1.6

Catalina.home=D:\ view\ SDCenter_v4.0 (R) _ 20151009\ SDCenter4.0

Java.class.path=D:\ view\ SDCenter_v4.0 (R) _ 20151009\ SDCenter4.0\ bin\ bootstrap.jar;D:\ view\ SDCenter_v4.0 (R) _ 20151009\ SDCenter4.0\ bin\ tomcat-juli.jar

User.name=comsys

Java.naming.factory.initial=org.apache.naming.java.javaURLContextFactory

Package.definition=sun.,java.,org.apache.catalina.,org.apache.coyote.,org.apache.tomcat.,org.apache.jasper.

Java.vm.specification.version=1.0

Sun.java.command=org.apache.catalina.startup.Bootstrap start

Java.home=C:\ Program Files\ Java\ jre6

Sun.arch.data.model=64

User.language=zh

Java.specification.vendor=Sun Microsystems Inc.

Awt.toolkit=sun.awt.windows.WToolkit

Java.vm.info=mixed mode

Java.version=1.6.0_45

Java.ext.dirs=C:\ Program Files\ Java\ jre6\ lib\ ext;C:\ Windows\ Sun\ Java\ lib\ ext

Sun.boot.class.path=C:\ Program Files\ Java\ jre6\ lib\ resources.jar;C:\ Program Files\ Java\ jre6\ lib\ rt.jar;C:\ Program Files\ Java\ jre6\ lib\ sunrsasign.jar;C:\ Program Files\ Java\ jre6\ lib\ jsse.jar;C:\ Program Files\ Java\ jre6\ lib\ jce.jar;C:\ Program Files\ Java\ jre6\ lib\ charsets.jar;C:\ Program Files\ Java\ jre6\ lib\ modules\ modules C:\ Program Files\ Java\ jre6\ classes

Server.loader=

Java.vendor=Sun Microsystems Inc.

Catalina.base=D:\ view\ SDCenter_v4.0 (R) _ 20151009\ SDCenter4.0

File.separator=\

Java.vendor.url.bug= http://java.sun.com/cgi-bin/bugreport.cgi

Common.loader=$ {catalina.base} / lib,$ {catalina.base} / lib/*.jar,$ {catalina.home} / lib,$ {catalina.home} / lib/*.jar

Sun.io.unicode.encoding=UnicodeLittle

Sun.cpu.endian=little

Package.access=sun.,org.apache.catalina.,org.apache.coyote.,org.apache.tomcat.,org.apache.jasper.

Sun.desktop=windows

Sun.cpu.isalist=amd64}

WARN [Thread-3] [org.apache.commons.httpclient.HttpMethodBase] (HttpMethodBase.java:682)-Going to buffer response body of large or unknown size. Using getResponseBodyAsStream instead is recommended.

INFO [localhost-startStop-1] [com.mchange.v2.log.MLog] (MLog.java:80)-MLog clients using log4j logging.

INFO [localhost-startStop-1] [com.mchange.v2.c3p0.C3P0Registry] (C3P0Registry.java:204)-Initializing c3p0-0.9.1 [built 16-January-2007 14 com.mchange.v2.c3p0.C3P0Registry 42; debug? True; trace: 10]

INFO [localhost-startStop-1] [com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource] (AbstractPoolBackedDataSource.java:462)-Initializing c3p0 pool... Com.mchange.v2.c3p0.ComboPooledDataSource [acquireIncrement-> 3, acquireRetryAttempts-> 30, acquireRetryDelay-> 1000, autoCommitOnClose-> false, automaticTestTable-> null, breakAfterAcquireFailure-> false, checkoutTimeout-> 0, connectionCustomizerClassName-> null, connectionTesterClassName-> com.mchange.v2.c3p0.impl.DefaultConnectionTester, dataSourceName-> 1hge2cu9o1tsl8ijbmx9tf | 5fb271f1, debugUnreturnedConnectionStackTraces-> false, description-> null, driverClass-> oracle.jdbc.driver.OracleDriver, factoryClassLocation-> null, forceIgnoreUnresolvedTransactions-> false, identityToken-> 1hge2cu9o1tsl8ijbmx9tf | 5fb271f1, idleConnectionTestPeriod-> 60, initialPoolSize-> 3 JdbcUrl-> jdbc:oracle:thin:@127.0.0.1:1521:ORCL, lastAcquisitionFailureDefaultUser-> null, maxAdministrativeTaskTime-> 0, maxConnectionAge-> 0, maxIdleTime-> 60, maxIdleTimeExcessConnections-> 0, maxPoolSize-> 15, maxStatements-> 0, maxStatementsPerConnection-> 0, minPoolSize-> 3, numHelperThreads-> 3, numThreadsAwaitingCheckoutDefaultUser-> 0, preferredTestQuery-> null, properties-> {user=*, password=*}, propertyCycle-> 0, testConnectionOnCheckin-> false, testConnectionOnCheckout-> false, unreturnedConnectionTimeout-> 0, usesTraditionalReflectiveProxies-> false]

The cause of the problem:

Because tomcat connects to the oracle database, the user is locked, resulting in an error.

Solution:

Enter the oracle database and unlock the user

Alter user user_name account unlock

After restarting tomcat, it returns to normal

This is the answer to the question about how to solve the problem of tomcat reporting an error due to database users being locked. I hope the above content can be of some help to you. If you still have a lot of doubts to be solved, you can follow the industry information channel for more related knowledge.

Tags: Questions data databases users methods more help answers easy easy content reasons guys partners knowledge articles industry information information channels channels Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Xiaomi Huawei NVidia Shulou Technology Shulou Tech Info