How to solve the kafka startup error broker.id 0 doesn't match stored broker.id 1 in meta.properties
This article mainly explains "kafka startup error broker.id 0 doesn't match stored broker.id 1 in meta.properties how to solve", interested friends may wish to have a look. The method introduced in this paper is simple, fast and practical. Next, let the editor take you to learn how to solve the kafka startup error broker.id 0 doesn't match stored broker.id 1 in meta.properties.
Error screenshot:
Cause:
Generally speaking, after starting a single kafka successfully, copying the entire kafka to another server only modifies the broker.id in the server.properties.
Solution:
The broker.id configured in the meta.properties in the log.dirs directory is inconsistent with the broker.id in the server.properties in the configuration directory. The solution is to modify the two and then restart them.
At this point, I believe you have a deeper understanding of "kafka startup error broker.id 0 doesn't match stored broker.id 1 in meta.properties how to solve". You might as well do it in practice. Here is the website, more related content can enter the relevant channels to inquire, follow us, continue to learn!