Tomcat port 8080 is occupied
2 solutions:
1. Close the process occupying port 8080: If port 8080 is occupied, execute startup.bat to report an error. You can execute netstat-ano command under cmd to check whether 8080 is occupied. If it is occupied, you can find and close the corresponding process in Task Manager according to the corresponding PID number, and then restart tomcat. The disadvantage of this method is that the port is occupied and the above operation has to be repeated.
2. Change tomcat port: Enter tomcat installation directory\conf folder, open service.xml with Notepad, specify new port number as shown below and restart tomcat.
This article is reproduced from: blog.csdn.net/sevenous/article/details/79101516