Get the App
SLTechnology News&Howtos  ›  Database  › 

Alarm problems encountered in 12c-rac installation (SCAN)

Shulou Source: shulou.com Published: 2022-06-01 12:47:33 10月04日 Update

I. description

There is always an alarm when installing the pre-check of the oracle 12c rac graphical interface, which looks very uncomfortable. The alarm message is as follows

INFO: PRVF-4664: Found inconsistent name resolution entries for SCAN name "testE-scan"

II. Description on the official website

Check the official website according to the prompt.

PRVF-4664 PRVF-4657: Found inconsistent name resolution entries for SCAN name (document ID 887471.1) APPLIES TO:

Oracle Database-Enterprise Edition-Version 11.2.0.1 and later

Information in this document applies to any platform.

PURPOSE

RunInstaller (OUI) reports INS-20802 while running Oracle Cluster Verification Utility post check after successful 11gR2 Grid Infrastructure clusterware (CRS) installation or upgrade:

Installation log-$ORACLE_BASE/oraInventory/logs/installActions {$TIMESTAMP} .log

INFO: PRVG-1101: SCAN name "cluscan.us.oracle.com" failed to resolve

INFO: ERROR:

INFO: PRVF-4664: Found inconsistent name resolution entries for SCAN name "cluscan.us.oracle.com"

INFO: ERROR:

INFO: PRVF-4657: Name resolution setup check for "scanclunm" (IP address: 10.4.0.202) failed

OR

PRCS-1016: Failed to resolve Single Client Access Name cluscan.us.oracle.com

If "$GRID_HOME/bin/cluvfy comp scan" is executed, similar message will be reported.

DETAILS

Cause 1. SCAN name is expected to be resolved by local hosts file

SCAN name is resolved by local hosts file (/ etc/hosts or% SystemRoot%\ system32\ drivers\ etc\ hosts) instead of DNS or GNS

Solution: Oracle strongly recommend to use DNS or GNS for SCAN name resolution as hosts file support only one IP for SCAN

If the intention is to use hosts file for SCAN name resolution, and ping command returns correct SCAN VIP, you can ignore the error and move forward.

If the intention is to use DNS or GNS for SCAN name resolution, comment out entries in local hosts file for SCAN name on all nodes, and re-run "$GRID_HOME/bin/cluvfy comp scan" to confirm.

In my environment, SCAN VIP uses the / etc/hosts file to parse, so this problem arises, and you can just skip this alarm during installation.

Tags: Time problem comfort information graphics official website file document environment interface website prompt check Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Microsoft Apple MySQL Redmi MariaDB