Hbase stand-alone installation
1. System version
2. Installation
3. Test it.
4. Points for attention
1. System version
Version: linux centos6.8
Hbase version: hbase-1.3.1
Jdk version
[root@test hbase] # java-version
Java version "1.8.0mm 121"
Java (TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot (TM) 64-Bit Server VM (build 25.121-b13, mixed mode)
2. Installation
# extract hbase to the / opt/hadoop/ directory and get a soft link
# configuration / etc/hosts file
# Note that the line 127.0.0.1 must be annotated, otherwise hbase will report an error when it starts up.
# add a line to your host IP address, host hostname, such as 192.168.1.1 test
# configure conf/hbase-env.sh# here configure the directory of the jdk you installed
Export JAVA_HOME=/usr/java/default/
# configure conf/hbase-site.xml
Hbase.rootdir
File:///opt/hadoop/hbase/data/# here is the installation directory self-defined directory
Hbase.master
192.168.1.The host IP, which can also be a hostname
Hbase.cluster.distributed
True
Hbase.zookeeper.property.clientPort
218mm zookeeper port
Hbase.zookeeper.quorum
192.168.1.The zookeeper address, which can also be a hostname
3. Test it.
# using bin/hbase shell
2017-12-07 13 util.NativeCodeLoader 21 util.NativeCodeLoader 03242 WARN [main]: Unable to load native-hadoop library for your platform... Using builtin-java classes where applicableHBase Shell Enter 'help' for list of supported commands.Type "exit" to leave the HBase ShellVersion 1.3.1, r930b9a55528fe45d8edce7af42fef2d35e77677a Thu Apr 6 19:36:54 PDT 2017hbase (main): 001main 0 > listTABLE account18 1 row (s) in 0.1570 seconds= > ["account18"]
4. Points for attention
# you can also log in using ip address: 16010. Check that master must not be localhost. If so, check the / etc/hosts file.