ORA-19606: Cannot copy or restore to snapshot control file
When I went to work this morning, I found that there was an error in deleting the mirror image of the control file of the expired backup. I hereby record that the following articles can be solved by querying mos:
Error ORA-19606 on RMAN Delete (document ID 1215493.1)
The idea is to uncatalog the specified expired image control file from the backup information recorded in the control file, as follows
SYMPTOMS:
= ODM Issue Clarification = =
Receiving error on 'delete obsolete':
Delete noprompt obsolete device type disk
RMAN retention policy will be applied to the command
RMAN retention policy is set to recovery window of 5 days
Deleting the following obsolete backups and copies:
Type Key Completion Time Filename/Handle
--
Control File Copy 3 01-SEP-10 C:\ APP\ ADMINISTRATOR\ PRODUCT\ 11.2.0\ DBHOME_1\ DATABASE\ SNCFAXMPRD.ORA
RMAN-00571: =
RMAN-00569: = ERROR MESSAGE STACK FOLLOWS =
RMAN-00571: =
RMAN-03009: failure of delete command on ORA_MAINT_DISK_1 channel at 09/09/2010 02:04:24
ORA-19606: Cannot copy or restore to snapshot control file
CAUSE:
= ODM Cause Determination = =
The snapshot controlfile is cataloged as a controlfile copy and is now obsolete. RMAN cannot delete this file as it is used by rman.
= ODM Cause Justification = =
Error and information supplied justifies cause
SOLUTION:
= ODM Solution / Action Plan = =
The snapshot controlfile must be removed as a valid controlfile copy. To do this, you would:
RMAN > change controlfilecopy'C:\ APP\ ADMINISTRATOR\ PRODUCT\ 11.2.0\ DBHOME_1\ DATABASE\ SNCFAXMPRD.ORA' uncatalog
Confirm with:
RMAN > list copy of controlfile