Get the App
SLTechnology News&Howtos  ›  Database  › 

Change the online redo log file prompt ORA-01511 ORA-01141

Shulou Source: shulou.com Published: 2022-06-01 06:24:42 10月04日 Update

Recently, a database is being migrated, using a full physical copy to the new environment, but the datafile directory needs to be changed. The previous environment preparation and physical copy went smoothly, but when the database was opened to read only mode, it was prompted that a standby log could not be read, so each redo log changed the storage location again.

Shut down the database and start the storage directory of shutdown immedaitestartup mount; change redo log file in mount state: alter database rename file 'old redo log file path' to 'new redo log file path'

There are 7 redo log files (plus 4 standby redo log), and only the fifth is unsuccessful.

ORA-01511: error in renaming log/data files ORA-01141: ORA-01110: ORA-27037: unable to obtain file status Linux Error: 2: No such file or directory

After searching for information, you need to clear the standyb redo log file you are using. The command is as follows:

Alter database clear unarchived logfile group x

Then change the location of the redo file again.

Tags: Data database prompt location copy file physical environment directory path storage success Prophase only command method is in mode being state Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Shulou Technology MySQL NVidia Microsoft MariaDB