Get the App
SLTechnology News&Howtos  ›  Database  › 

How to solve the problem of controlling user connection failure by phpmyadmin

Shulou Source: shulou.com Published: 2022-05-31 21:32:27 10月03日 Update

This article mainly introduces "how to solve the problem of control user connection failure by phpmyadmin". In daily operation, I believe many people have doubts about how to solve the problem of control user connection failure by phpmyadmin. Xiaobian consulted all kinds of materials and sorted out simple and easy-to-use operation methods. I hope it will be helpful for everyone to answer the doubt of "how to solve the problem of control user connection failure by phpmyadmin". Next, please follow the editor to study!

1. Here are the articles found on the Internet

Since I installed phpmyadmin using apt-get, check the configuration file and find that the config.inc.php under / usr/share/phpmyadmin actually maps to / etc/phpmyadmin/config.inc.php.

Open / etc/phpmyadmin/config.inc.php and follow the error prompt to find the code that controls the user:

$cfg ['Servers'] [$I] [' controluser'] = $cfg ['Servers'] [$I] [' controlpass'] =

Delete the things after the equal sign and change it to:

$cfg ['Servers'] [$I] [' controluser'] = 'root';$cfg [' Servers'] [$I] ['controlpass'] =' 123456'

123456 for your root password, save and refresh the phpmyadmin page using the control user connection defined in the configuration file failed. Problem solved.

Download an installation package corresponding to your phpmyadmin version under the web. What I download is: phpMyAdmin-3.2.2-all-languages.zip, extract the scripts/create_tables.sql file, log in to phpmyadmin, create a new database called phpmyadmin, and import the create_tables.sql file.

Then modify / etc/phpmyadmin/config.inc.php to:

$cfg ['Servers'] [$I] [' pmadb'] = 'phpmyadmin';$cfg [' Servers'] [$I] ['bookmarktable'] =' pma_bookmark';$cfg ['Servers'] [$I] [' relation'] = 'pma_relation';$cfg [' Servers'] [$I] ['table_info'] =' pma_table_info';$cfg ['Servers'] [$I] [' table_coords'] = 'pma_table_coords'] $cfg ['Servers'] [$I] [' pdf_pages'] = 'pma_pdf_pages';$cfg [' Servers'] [$I] ['column_info'] =' pma_column_info';$cfg ['Servers'] [$I] [' history'] = 'pma_history';$cfg [' Servers'] [$I] ['designer_coords'] =' pma_designer_coords'

Finally, restart mysql and apache.

However, I didn't solve it. Record it for the time being.

two。 Through one's own exploration

Several paths were found in the config.inc.php file

Through sudo find /-name config.inc.php

Find several paths

/ usr/share/phpmyadmin/setup/frames/config.inc.php/var/www/html/wordpress/phpmyadmin/config.inc.php/var/www/html/wordpress/phpmyadmin/setup/frames/config.inc.php/var/lib/phpmyadmin/config.inc.php/etc/phpmyadmin/config.inc.php

By reading the code inside, I found that

/ etc/phpmyadmin/config.inc.php

There are two guys in there, $dbuser and $dbpass.

Just change these two guys to your account and password to connect to the database, but you also need to restart apache and mysql.

3. To sum up.

There are a few questions: why did it change?

$cfg ['Servers'] [$I] [' controluser'] = $cfg ['Servers'] [$I] [' controlpass'] = in / etc/phpmyadmin/config.inc.php file

What if two variables don't work?

In fact, these two variables mean the configuration of super administrator username and password.

What actually works is $dbuser,$dbpass.

At this point, the study on "how to solve the problem of controlling user connection failure by phpmyadmin" is over. I hope to be able to solve everyone's doubts. The collocation of theory and practice can better help you learn, go and try it! If you want to continue to learn more related knowledge, please continue to follow the website, the editor will continue to work hard to bring you more practical articles!

Tags: User problem control file two learning password configuration code function variable actual guy data database article more path help practical Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Apple vpn Linux Huawei Xiaomi