Get the App
SLTechnology News&Howtos  ›  Database  › 

Oracle RAC failed to start (DNS failure)

Shulou Source: shulou.com Published: 2022-06-01 04:44:29 10月04日 Update

Question:

Database startup error: ORA-00119, ORA-00132, etc.

Environment:

DB:Oracle 11.2.0.4.0

OS:Redhat 6.5

Problem phenomenon:

Start the database error:

[grid@rac01] $srvctl start database-d cjcdb

PRCR-1079: Failed to start resource ora.cjcdb.dbCRS-5017: The resource action "ora.cjcdb.db start" encountered the following error: ORA-00119: invalid specification for system parameter REMOTE_LISTENERORA-00132: syntax error or unresolved network name 'rac-scan.cjc.com:1521'. For details refer to "(: CLSN00107:)" in "/ u01/app/11.2.0/grid/log/rac02/agent/crsd/oraagent_oracle/oraagent_oracle.log" .CRS-5017: The resource action "ora.cjcdb.db start" encountered the following error: ORA-00119: invalid specification for system parameter REMOTE_LISTENERORA-00132: syntax error or unresolved network name 'rac-scan.cjc.com:1521'. For details refer to "(: CLSN00107:)" in "/ u01/app/11.2.0/grid/log/rac01/agent/crsd/oraagent_oracle/oraagent_oracle.log" .CRS-2674: Start of 'ora.cjcdb.db' on' rac02' failedCRS-2674: Start of 'ora.cjcdb.db' on' rac01' failedCRS-2632: There are no more servers to try to place resource 'ora.cjcdb.db' on that would satisfy its placement policy

Where the parameter value of remote_listener is: rac-scan.cjc.com:1521

Suspect that DNS failed to parse SCAN

Log in to rac01 to execute nslookup rac-scan.cjc.com

[root@rac01 bin] # nslookup rac-scan.cjc.com;; connection timed out; trying next origin;; connection timed out; no servers could be reached

Check that the resolv.conf configuration information is emptied. In fact, every time the server restarts the Nic resolv.conf configuration will be emptied automatically.

[root@rac01 bin] # cat / etc/resolv.conf# Generated by NetworkManagernameserver 8.8.8.8

Check the DNS that does not specify 90 in the network card configuration file, and add the 90DNS manually.

[root@rac02 bin] # cd / etc/sysconfig/network-scripts/ [root@rac02 network-scripts] # vim ifcfg-eth0DNS1= "192.168.31.90"

Re-add resolv.conf configuration information

[root@rac01 bin] # vim / etc/resolv.conf# Generated by NetworkManagernameserver 8.8.8.8domain cjc.comnameserver 192.168.31.90options rotateoptions timeout:2options attempts:5

It can be parsed normally.

[root@rac01 bin] # nslookup rac-scan.cjc.comServer:192.168.31.90Address:192.168.31.90#53Name:rac-scan.cjc.comAddress: 192.168.31.60Name:rac-scan.cjc.comAddress: 192.168.31.70Name:rac-scan.cjc.comAddress: 192.168.31.50

Startup data

[root@rac01 bin] #. / srvctl start instance-d cjcdb-I cjcdb1 [root@rac01 bin] #. / srvctl start instance-d cjcdb-I cjcdb2

Check instance status

[root@rac01 bin] #. / srvctl status database-d cjcdbInstance cjcdb1 is running on node rac01Instance cjcdb2 is running on node rac02

Welcome to follow my Wechat official account "IT Little Chen" and learn and grow together!

Tags: Configuration data information database network card problem check public parameter instance actual actually manual file server status environment phenomenon learning service Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Redmi macOS vpn Huawei MySQL