Get the App
SLTechnology News&Howtos  ›  Database  › 

ORA-01119 ORA-17502 ORA-15041

Shulou Source: shulou.com Published: 2022-06-01 15:02:23 10月04日 Update

ERROR at line 1:ORA-01119: error in creating database file'+ DATA'ORA-17502: ksfdcre:4 Failed to create file + DATAORA-15041: diskgroup "DATA" space exhaustedgrid@1618db01:/home/grid$ asmcmd lsdgState Type Rebal Sector Block AU Total_MB Free_MB Req_mir_free_MB Usable_file_MB Offline_disks Voting_files NameMOUNTED EXTERN Y 4096 1048576 37376000 1682102 0 1682102 0 N DATA/MOUNTED NORMAL N 4096 1048576 30720 29542 10240 9651 0 Y OCR/ 1 * select * from v$asm_operationGROUP_NUMBER OPERA STAT POWER ACTUAL SOFAR EST_WORK EST_RATE EST_MINUTES ERROR_CODE -2 REBAL RUN 10 10 744251 1225787 7061 68

Background:

First expand the capacity of the data disk-4t

Then add tablespace-3t

After adding 2.5t, the error of disk space is reported.

Check that data disk space is sufficient, data disk group is rebalance

Exadata: Create TableSpace Fails with ORA-01119 ORA-17502 ORA-15041: Diskgroup Space Exhausted Despite Plenitude of Free Space is Present (document ID 2372651.1)

According to the solutions available on mos are as follows

It probably means

Check the disk group data first.

Conduct rebalance.

Wait until the rebalance is over.

Re-add the data file.

Note: if you encounter an error report, which leads to an error in rebalance, re-execute rebalance

Tags: Disk space error check adequacy meaning data file document solution in progress background solution Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Docker NVidia Redmi Shulou Technology Microsoft