Oracle failed to log in with sqlplus using administrator account, prompting ERROR
Beginner Oracle, no account password, want to try to use the administrator account to see which users and lists after the computer, the Internet to find a lot of posts, at the beginning, with
Sqlplus / nolog
It was a success.
However, with
Sqlplus "/ as sysdba"
Is a failure, and prompts
ERROR:
ORA-12560: TNS: protocol adapter error
We still need to log in, which is very confusing. I don't know the password. I tried one by one according to the online post, but all failed.
All right, let's go to the text:
According to the online post to solve the ORA-12560: TNS: protocol adapter error, found that under my WIN7 computer
Start-programs-management tools-services, open the services panel, there is no OracleOraDb11g_home1TNSListener,OracleServiceORCL service. (the picture is crossed out because I have successfully solved the problem.)
Resolution steps:
1. Run as an administrator
two。 Enter and enter
Oradim-new-sid orcl-startmode auto-srvcstart system
3. Open the start-program-management tools-services, open the services panel, and start the service that marks the image.
(not OracleOraDb11g_home1TNSListener, but more OracleOraDb11g_home2TNSListener, no entanglement)
4. Normal permission to run
5. Input
Sqlplus "/ as sysdba"
Success
Think of the source of drinking water, send out the reference post for your reference: https://bbs.csdn.net/topics/390688143