Get the App
SLTechnology News&Howtos  ›  Database  › 

Error handling of oracle instance creation

Shulou Source: shulou.com Published: 2022-06-01 07:54:02 10月03日 Update

Error when executing dbca after installing oracle

Sh:/bin/ksh:Nosuch file or directory

Suspected that the KSH package, yum installksh, is not installed.

Got it!

File "/ etc/oratab" is not accessible

It turns out that the root.sh script was not executed, but was executed in the oracle home directory (cd$ORACLE_HOME) under the product/11.2.0/db_1/ directory. / root.sh

There are still errors reported after the execution.

ORA-00119: invalid specification for system parameter LOCAL_LISTENER

ORA-00132: syntax error or unresolved network name'LISTENER_ORCL'

Suspected is the problem of monitoring, lsnrctlstart failed to start, the specific error message is not clear, so re-add monitoring.

An error was reported while executing netca

TNS-12545 Connect failed because target host or object does not exist

After checking, it is because the tnsname.ora file does not exist, because I did not install oracle, it is not clear why there is no such file. So I copied a copy from another server:

# tnsnames.ora Network Configuration File:/u01/app/oracle/product/11.2.0/db_1/network/admin/tnsnames.ora

# Generated by Oracle configuration tools.

Oracle11g=

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP) (HOST = *. *) (PORT = 1521))

)

(CONNECT_DATA =

(SERVER = DEDICATED)

(SID = orcl)

)

)

ORCL =

(DESCRIPTION =

(ADDRESS = (PROTOCOL = TCP) (HOST = oracle) (PORT = 1521))

(CONNECT_DATA =

(SERVER = DEDICATED)

(SERVICE_NAME = orcl)

)

Lsnrctl is executed after the copy, and the listening starts successfully.

When performing startup

SQL > startup

ORA-00845: MEMORY_TARGET not supported on this system

Root@test~] # cat / etc/fstab | grep tmpfs

Tmpfs / dev/shm tmpfs defaults 0 0

Remount the shm partition mount-oremount,size=8G / dev/shm

Modify fstab to make it permanent vi/etc/fstab

/ dev/mapper/vg_ccbfpp-lv_home/home ext4 defaults 1 2

/ dev/mapper/vg_ccbfpp-lv_swap swap swap defaults 0 0

Tmpfs / dev/shm tmpfs defaults 0 0

Devpts / dev/pts devpts gid=5,mode=620 0 0

Sysfs / sys sysfs defaults 0 0

Proc / proc proc defaults 0 0

Tmpfs / dev/shm tmpfs defaults,size=16g 0 0

Df-h | grepshm

Tmpfs 8G 0 16G 0% / dev/shm

SQL > startup

ORACLE instancestarted.

Total SystemGlobal Area 9420095488 bytes

FixedSize 2236248 bytes

VariableSize 2315255976 bytes

DatabaseBuffers 7046430720 bytes

RedoBuffers 56172544 bytes

Databasemounted.

Databaseopened.

SQL > exit

What a twist and turn.

Tags: Time monitor copy file directory clear success twists and turns information server script or problem too clear wave permanent service check instance processing Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Shulou Information Microsoft MySQL Docker NVidia