How to deal with Mysql error report by The server quit without updating PID file
This article mainly tells you briefly how to deal with Mysql error The server quit without updating PID file. You can check the relevant professional terms on the Internet or find some related books to supplement them. We will not dabble here. Let's go straight to the topic. I hope this article on how to deal with Mysql error The server quit without updating PID file can bring you some practical help.
When mysql is installed, it does not report a successful error when starting after installation:
Starting MySQL.. ERROR! The server quit without updating PID file (/ data/mysql/26765574162f.pid).
View the error log:
[ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist
Solution:
1. Edit the configuration file:
Vim / etc/my.cnfbasedir = / usr/local/mysqldatadir = / data/mysqlsocket = / tmp/mysql.socklog-error = / data/mysql/error.logpid-file = / data/mysql/mysql.piduser = mysqltmpdir = / tmp
two。 Reinitialize mysql:
. / mysql_install_db-user=mysql-basedir=/usr/local/mysql-datadir=/data/mysql-pid-file=/data/mysql/mysql.pid-tmpdir=/tmp
Then start it again and it will be successful:
Mysql error The server quit without updating PID file how to deal with the first to tell you here, for other related issues you want to know can continue to pay attention to our industry information. Our section will capture some industry news and professional knowledge to share with you every day.