A solution to the failure of incremental update of CDH4,lily,hbase solr indexer
The operation and maintenance staff monitored that the index could not be updated incrementally. After positioning, it was found that hbase solr indexer did not take effect.
In the past, the test environment was usually caused by the failure of the hbase-solr-indexer process. But this time is different.
Check the source code of sep's impl and find that it is disguised as a HbaseRegionServer, using itself as a slave, and then with the help of HBase's replication mechanism, let log copy over. It then gets the incremental update content through write ahead log.
The guess is that the mechanism has been broken. Check zookeeper
Ls / ngdata/sep/hbase-slave/Indexer_morphlines_Test300/rs
Found this record.
[datanode10.bjpuc1.quanshi.com,50475,1428377032454]
Check hbase
Ls / hbase/rs
[datanode8.app.company.com,60020,1427557044871,datanode3.app.company.com,60020,1428140476654, datanode6.app.company.com,60020,1427557034896,datanode10.app.company.com,60020,1427557054164,datanode1.app.company.com,60020,1427556940973,datanode7.app.company.com,60020,1427557039934,datanode4.app.company.com,60020,1427557024791, datanode9.app.company.com,60020,1427557048966,datanode2.app.company.com,60020,1427557014498,datanode11.app.company.com,60020,1427557059497,datanode5.app.company.com,60020,1427557029513]
Therefore, it is suspected that there is a problem with the synchronization of the two. So let Junfu help rebuild an incremental update configuration. The way to do this is to delete the original hbase-solr-indexer configuration and then re-add-indexer it.
Ls/ngdata/sep/hbase-slave/Indexer_morphlines_Test300/rs
[datanode10.app.company.com,2074,1428455398626]
The problem has been solved.