Get the App
SLTechnology News&Howtos  ›  Database  › 

The method of realizing SQLSERVER Advanced replication debugging

Shulou Source: shulou.com Published: 2022-05-31 17:39:21 09月30日 Update

This article mainly introduces "the method of realizing SQLSERVER advanced replication debugging". In the daily operation, I believe that many people have doubts about the method of realizing SQLSERVER advanced replication debugging. The editor consulted all kinds of materials and sorted out simple and easy-to-use operation methods. I hope it will be helpful to answer the doubts of "realizing SQLSERVER advanced replication troubleshooting methods". Next, please follow the editor to study!

Copy error troubleshooting case

Wang Jingzheng

I. configuration error

1. Phenomenon: SQL Server Scheduled Job 'replication Agent check' (0x8B6402EFE814B543A112E5A5A5FBB8CF)-Status: failed-Invoked on: 2007-07-20 08:50:01-Message: job failed. Unable to determine whether the owner (WANGJINGZHENG\ Administrator, who has the job replication agent check) has access to the server (because information about the Windows NT group / user 'WANGJINGZHENG\ Administrator' could not be obtained. [SQLSTATE 42000] (error 8198).

2. Troubleshooting steps: it seems to be caused by NT users. Change the registration of SQLSERVER to SA instead of NT, and the result is successful. After checking the full name of the server, it is found that the server has been changed to a domain controller, and the domain name is learn.com, then the full sentence is wangjingzheng.learn.com. This shows that the cause of the failure is that before the server was upgraded to a domain controller, its built-in NT login account in SQLSERVER was wangjingzheng\ administrator. When the server has been upgraded, the user sentence should be learn\ administrator, so the original account has become invalid.

3. Delete the original wangjingzheng\ administrator, re-add the administrator account learn\ administrator, and then reconfigure to troubleshoot the problem.

4. Check that the startup account of the SQLSERVER and SQLSERVERAGENT services is still.\ administrator, which can be changed to a domain account.

At this point, the study of "how to achieve SQLSERVER advanced replication debugging" is over. I hope to be able to solve your doubts. The collocation of theory and practice can better help you learn, go and try it! If you want to continue to learn more related knowledge, please continue to follow the website, the editor will continue to work hard to bring you more practical articles!

Tags: Services methods servers accounts advanced learning checking users reasons controllers more thus programs errors problems agents jobs upgrades help control Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno vpn macOS OPPO Reno Shulou Information NVidia