Get the App
SLTechnology News&Howtos  ›  Database  › 

Oracle startup error message-caused by hostname

Shulou Source: shulou.com Published: 2022-06-01 10:06:01 09月29日 Update

# at the beginning, log in to the root user directly. In the etc directory, change to oracle, and enter lsnrctl start to prompt "lsnrctl: command not found" [root@loveyao_test etc] # su oracle @ loveyao_test etc] $lsnrctl startbash: lsnrctl: command not found# to switch back to the root user, cd / root directory, su-oracle again, and type lsnrctl start to start oracle. This time it's normal. [oracle@loveyao_test ~] $cd / [oracle@loveyao_test /] $su-rootsu: invalid option-- 'r'Try `su-- help' for more information. [oracle @ loveyao_test /] $su-rootPassword: [root@loveyao_test ~] # su-oracle @ loveyao_test ~] $[oracle@loveyao_test ~] $lsnrctl startLSNRCTL for Linux: Version 11.2.0.3.0-Production on 04-JUL-2016 22:06:57Copyright (c) 1991, 2011, Oracle. All rights reserved.Starting / u01/app/oracle/product/11.2.0/db_1/bin/tnslsnr: please wait...TNSLSNR for Linux: Version 11.2.0.3.0-ProductionLog messages written to / u01/app/oracle/diag/tnslsnr/loveyao_test/listener/alert/log.xmlError listening on: (ADDRESS= (PROTOCOL=tcp) (HOST=) (PORT=1521)) TNS-12545: Connect failed because target host or object does not exist TNS-12560: TNS:protocol adapter error TNS-00515: Connect failed because Target host or object does not exist Linux Error: 25: Inappropriate ioctl for deviceListener failed to start. See the error message (s) above. [oracle @ loveyao_test] $# as shown above: oracle failed to start, prompting "Error listening on: (ADDRESS= (PROTOCOL=tcp) (HOST=) (PORT=1521)) TNS-12545: Connect failed because target host or object does not exist" # hosts file, switch root to modify hosts file, restart oracle can start normally. The specific operations are as follows: [oracle@loveyao_test alert] $su-rootPassword: [root@loveyao_test ~] # [root@loveyao_test ~] # [root@loveyao_test ~] # vi / etc/hosts127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4::1 localhost localhost.localdomain localhost6 localhost6.localdomain6~# modify the hosts file localhost to the hostname hostname Note: vi / etc/sysconfig/network file can change the name of hostname (here you need to restart the system after modification). [root@loveyao_test ~] # vi / etc/hosts127.0.0.1 loveyao_test localhost.localdomain localhost4 localhost4.localdomain4::1 localhost localhost.localdomain localhost6 localhost6.localdomain6~ [root@loveyao_test ~] # su-Oracle [loveyao_test ~] $lsnrctl startLSNRCTL for Linux: Version 11.2.0.3.0-Production on 04 -JUL-2016 22:23:22Copyright (c) 1991 2011, Oracle. All rights reserved.Starting / u01/app/oracle/product/11.2.0/db_1/bin/tnslsnr: please wait...TNSLSNR for Linux: Version 11.2.0.3.0-ProductionLog messages written to / u01/app/oracle/diag/tnslsnr/loveyao_test/listener/alert/log.xmlListening on: (DESCRIPTION= (ADDRESS= (PROTOCOL=tcp) (HOST=loveyao_test) (PORT=1521)) Connecting to (ADDRESS= (PROTOCOL=tcp) (HOST=) (PORT=1521)) STATUS of the LISTENER- -Alias LISTENERVersion TNSLSNR for Linux: Version 11.2.0.3.0-ProductionStart Date 04-JUL-2016 22:23:22Uptime 0 days 0 hr. 0 min. 0 secTrace Level offSecurity ON: Local OS AuthenticationSNMP OFFListener Log File / u01/app/oracle/diag/tnslsnr/loveyao_test/listener/alert/log.xmlListening Endpoints Summary... (DESCRIPTION= (ADDRESS= (PROTOCOL=tcp) (HOST=loveyao_test) (PORT=1521) The listener supports no servicesThe command completed listening [oracle @ loveyao_test ~] $# View oracle listening port 1521 [oracle@loveyao_test ~] $ss-tanlRecv-Q Send-Q Local Address:Port Peer Address:Port 0128: 111: : * 0128 *: 1521: * 0128: 25493 : * 0 128: 22: * 0 128 *: 22 *: * 0 128 127.0.0.1 purl 631 *: * 0128:: 1Partition 631: * 0100:: 1:25: * 0100 127.0.0. 1:25 *: * 0128 *: 39108 *: * [oracle@loveyao_test ~] $

Tags: File switch prompt name user input host again such as above root directory directory port system login monitoring reason error Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno macOS MySQL Docker OPPO Reno Redmi